#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<script\b[^>]*>[\s\S]*<\/script>"
Local $sString = "<body>" & @CRLF & _
" <temlate></template>" & @CRLF & _
" <script>" & @CRLF & _
" var str = `<script>var html='abc';</script>" & @CRLF & _
" <style></style>" & @CRLF & _
" `;" & @CRLF & _
" </script>" & @CRLF & _
"" & @CRLF & _
" <style></style>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")