using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script\b[^>]*>[\s\S]*<\/script>";
string input = @"<body>
<temlate></template>
<script>
var str = `<script>var html='abc';</script>
<style></style>
`;
</script>
<style></style>
</body>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}