package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<script\b[^>]*>[\s\S]*<\/script>`)
var str = `<body>
<temlate></template>
<script>
var str = \`<script>var html='abc';</script>
<style></style>
\`;
</script>
<style></style>
</body>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}