#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)https?://" & @CRLF & _
"(?:www\.)?" & @CRLF & _
"((?:[a-z][a-z0-9-]*[a-z0-9]\.|[a-z]\.)+" & @CRLF & _
" (?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))"
Local $sString = "http://0.example.com" & @CRLF & _
"http://www.www.example.com" & @CRLF & _
"https://dash-dash.example.com" & @CRLF & _
"http://-dash.example.com" & @CRLF & _
"https://dash-.example.com" & @CRLF & _
"http://some.something.com" & @CRLF & _
"https://www.helloworld.com" & @CRLF & _
"http://apple.www.example.com" & @CRLF & _
"https://example-2.com" & @CRLF & _
"http://awww.example.com" & @CRLF & _
"TV.S1E01.mp4" & @CRLF & _
"ssh://example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")