package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2})(AB)`)
var str = `blahblah11AB12AB13ABblah22AB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}