$re = '/(?:^.*?\K|\G)(\d{2})(AB)/m';
$str = 'blahblah11AB12AB13ABblah22AB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);