const regex = /'(?:.* _\n)*.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'(?:.* _\\n)*.*', 'gm')
const str = `Hello Colm "This is a test""\\\\"
"This is also an NL test"
'And this has an escaped quote don\\'t in it ' Blue Boy
'euaoeu _
uaoeuaoeu _
uaoeuaoek
"This has a single quote ' but doesn\\' end the quote as it started with double quotes" 'comment
"""line spanning with escaped quote at the end of a line""" 'comment
""""
"Foo Bar" "Another Value" something else`;
const subst = `'cmt`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);