import Foundation
let pattern = #"(?<!\w)\d+(?<!\")"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc" 234234 =2345234
sdhjaklf382as;ldfj asda2334= 76555
=123123
:1233
"gnhgnghb grhgf ytjy4444 rewgefgg
gfbvc"
"gnhgnghb grhgf ytjy 4444 rewgefgg
gfbvc"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)