#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[,\s]?([A-Za-z. '\s/()\"]+)?(Manager|manager)([A-Za-z. '\s/()]+)?(?=,)"
Local $sString = "id,First Name,Last Name,Current Job1,Current Job2,PastJob1,PastJob2,PastJob3,Nan" & @CRLF & _
"0,Amanda,Maldonado,Recruiter,NA,Sales Associate,Waitress,Office Assistant,1" & @CRLF & _
"1,Ashley,Galetti,Project Manager,NA,Front of house manager,NA,NA,1" & @CRLF & _
"2,Brent ,Tally,President,NA,Director of Construction,NA,NA,1" & @CRLF & _
"3,Chris,Rodriguez,Sec/Treasure,Co-owner,NA,NA,NA,1" & @CRLF & _
"4,Corey,Miller,Top Ranked Multi-Unit Director,NA,Regional Director Services,Regional Installed Sales Director,Area Installation Manager,1" & @CRLF & _
"5,Cristian,Turcios,Project Assistant,NA,Contractor,NA,NA,1" & @CRLF & _
"6,David,Cone-Gorham,Owner,NA,"Vice President, Regional Director",Division Manager/ Executive Recuiter,NA,1" & @CRLF & _
"7,Devin,Rivers,Sr. Account Executive,NA,Full Desk Account Executive,NA,NA,1" & @CRLF & _
"8,Douglas W.,Fletcher,Deputy Construction Group Manager,NA,Construction Director,Operation Manager,Vice President of Construction,1" & @CRLF & _
"9,Dustin,Cox,Contracts Administrator,NA,Contracts / Operations Manager,Contract Administrator,Golden Contracts System Specialist,1" & @CRLF & _
"10,Eddie,Martinez,Vice President of Membership,Director of Safety and Risk,Construction manager,Assistant Project Manager,NA,1" & @CRLF & _
"11,Eric,Buckner,Sr. Construction Management Consultant,NA,"Director, Project Operations","Director, Construction Resource Management",Project Manager/Site Manager,1" & @CRLF & _
"12,George,Dokos,Construction Recruiter,NA,President-Recruiter,Construction Recruiter,Construction Recruiter,1" & @CRLF & _
"13,Jay,Mogge,Co-Owner,Construction Manager,Senior Project Manager,Officer,NA,1" & @CRLF & _
"14,Jeff,Crenshaw,Construction Risk Management and advisor,NA,Sales,Scout Sniper Platoon Sergeant,Sales,1" & @CRLF & _
"15,Jeremy,Rainwater,Construction Field Manager,NA,Assistant Field Manager,General Manager,National Production Manager,1" & @CRLF & _
"16,Jim ,Conlow,General Contractor,NA,ReDevelopment Director,"Division Manager, Energy Projects",Construction; Development Management - President,1" & @CRLF & _
"17,Jimmy,Fong,Recruiter,NA,Production Specialist,Sales Representative,Specialist,1" & @CRLF & _
"18,Joe,Walton,Builder,Professional Home Inspector,Field Manager II,Construction Manager,NA,1" & @CRLF & _
"19,Keith,Eaton,Janitorial/Maintenance,NA,Project Manager,Project Manager/Engineer,Project Manager/Engineer,1" & @CRLF & _
"20,Kenneth,Dunn,T&D Outage Planner,NA,Construction Manager,Project Manager,Superintendent,1" & @CRLF & _
"21,Lauren,Stafford,Senior Sales Manager,Sales Manager,Sales Support Coordinator,Builder relations,Customer Experience Lead,1" & @CRLF & _
"22,Mike,Seery,President,President,Project Manager,Managing Partner,NA,1" & @CRLF & _
"23,Paul,Horn,Sales Estimator,NA,Territory Sales Manager,Territory Sales Manager,National Account Manager,1" & @CRLF & _
"24,Paul,Pollesch,Design and Construction Services Manager,NA,Assistant Operations and Maintenance Officer,MSCE Graduate Student,Company commander/ Assistant Operations Officer,1" & @CRLF & _
"25,Paul ,Hooks,Vice president of Construction Management,NA,Project Manager,Project Manager/Interiors Division Manager,NA,1" & @CRLF & _
"26,Ray ,LaMonica,"Project Controls, Engineering, Construction Management Recruiter",Account Recruiting Manager,Territory Sales Executive,Business Account Executive,NA,1" & @CRLF & _
"27,Ray ,Meyer,Vice President,Adjunct Professor/Construction Management,NA,NA,NA,1" & @CRLF & _
"28,Roy ,Flournoy,Superintendent,NA,Project Manager,Superintendent,Superintendent,1" & @CRLF & _
"29,Roy ,Allen,Owner,NA,Construction Project management & Project superintendent,Construction Project Manager and Project Superintendent,Construction Project Manager and Project Superintendent,1" & @CRLF & _
"30,Ryan,Salladay,Senior Recruiter,NA,Sales Executive,Associate Vice President of Sales,Fitness professional,1" & @CRLF & _
"31,Sam,ller,Principal,NA,Director of Safety Services,Director of Field Safety Operations,Owner,1" & @CRLF & _
"32,Steven,Hadley,President,Construction Management Alumni,Director of Program Management,Estimator,Realtor,1" & @CRLF & _
"33,Stewart,Scott,Project Executive,NA,"Vice President of Engineering, Program Management","Corporate Vice President Capital Projects, Property Management",Senior Project Manager,1" & @CRLF & _
"34,Suadad,Al tameemi,Construction Inspector,NA,Quality Inspector,Planning Manager and Supervising Engineer,"Scheduler, Supervisor Engineer",1" & @CRLF & _
"35,Tony,Pacifico,Senior Project Manager,NA,Senior Project Manager,Construction Management Consultant,Senior Project Manager,1" & @CRLF & _
"36,Truitt,Rounsavall,Project Manager,NA,Facilities Manager (Contract),Program Manager,Project Manager,1" & @CRLF & _
"37,Virgil,Gray,Vice president of Construction Management,NA,Manager of Construction Services,"Principal Consultant, Program Management Office (PMO)",Vice President,1" & @CRLF & _
"38,Zach,Kempthorne,Project Management Consultant,NA,Project superintendent,Project Superintendent,Project Manager/Operations Manager,1" & @CRLF & _
""
Local $sSubst = ",3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)