# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+//gm;t' <<< "7,673,656.87
427,870.27
7,401.38
102,393.11
2,340,692.03
2,093,675.04
"