# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[^.]+\.){4}/$&USA./gi;t' <<< "12345.001.chris_comp.NY.2023_08_22.xlsx"