const regex = new RegExp('(?:[^.]+\\.){4}', 'gi')
const str = `12345.001.chris_comp.NY.2023_08_22.xlsx`;
const subst = `$&USA.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);