$re = '/(?<version>[0-9]*.[0-9]*).(?<patch>[0-9]*).(?<build>[0-9]*)/';
$str = '1.2.343.22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);