# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^FLST,\d+,\d+,(\d),.*?$\n((^FITEM,\d+,\d+\s*$\n)+).*?(^[^\n]*?,P51X.*?$\n)"
test_str = ("!* \n"
"CMDELE,_Y \n"
"CMDELE,_Y1 \n"
"CMDELE,_Y2 \n"
"!* \n"
"FLST,2,1,5,ORDE,1 \n"
"FITEM,2,33 \n"
"!* \n"
"/GO \n"
"DA,P51X,ALL,\n\n\n"
"aplot \n"
"/UI,MESH,OFF\n"
"/inquire,aeChWmsy,psearch \n"
"/inquire,cGe7Wl8b,p\n"
"keyopt,etype_,1,1 \n"
"*SET,areas_,0 \n"
"FLST,5,2,5,ORDE,2 \n"
"FITEM,5,14 \n"
"FITEM,5,18 \n"
"ASEL,S, , ,P51X \n"
"asum\n"
"*get,x_,area,0,cent,x \n"
"*get,y_\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.