use strict;
my $str = 'Пример 1 (здесь все ок):
start"content"
Пример 2 ("content" должны подсвечиваться в отдельную от запятых группу):
start"content", "content content", "content content", "content"
Пример 3 (здесь все ок):
start"content", start"content",start"content content", start"content"
Пример 4 (не должно подсвечиваться т.к. нет начального условия):
"content", "content content","content", "content"
Другое:
(,?\\s*)
(?<=start)((\\".*?\\")(,\\s*)?)*
(?<=start)(\\".*?\\"),?\\s*((\\".*?\\"),?\\s*)*';
my $regex = qr/(?<=start)((\".*?\")(,\s*)?)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}