$re = '/(123)/';
$str = '123684
123125
454521235745';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);