// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\BN\B").unwrap();
let string = "\"Peronospora boniNhenrici\",\"Cystoseira abiesNmarina\",\"Niplommatina rubra\",
\"Padina sanctaeNcrucis\",\"Nachygrapsus NaurusNliguricus\",\"Melphidippa borealis\"";
let substitution = "-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}