package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\.city\.).*?(\.checked)\]`)
var str = `.city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]
`
var substitution = "$1poolavailable$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}