import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\.city\\.).*?(\\.checked)\\]";
final String string = ".city.playground[?(@.playhouse == 'true' && @.IsPoolAvailable=='true')].checked]\n";
final String subst = "$1poolavailable$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}