re = /(\.city\.).*?(\.checked)\]/m
str = '.city.playground[?(@.playhouse == \'true\' && @.IsPoolAvailable==\'true\')].checked]
'
subst = '$1poolavailable$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result