import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(//)[^@]*(@)";
final String string = "http_proxy=\"http://QQ@127.0.0.1:8080/\"\n"
+ "http://test1:test2@127.0.0.1:8080/\n"
+ "http_proxy=\"http://QQ@127.0.0.1:8080/\n"
+ "http://@127.0.0.1:8080/\"";
final String subst = "\\1user:pass\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}