re = /(\/\/)[^@]*(@)/m
str = 'http_proxy="http://QQ@127.0.0.1:8080/"
http://test1:test2@127.0.0.1:8080/
http_proxy="http://QQ@127.0.0.1:8080/
http://@127.0.0.1:8080/"'
subst = '\\1user:pass\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result