re = /public\sfunction\sset(.*[(])(?!\?)(?'type'string|int|array|float)/m
str = 'public function setFirstName(?string $firstName)
public function setLastName(string $lastName)
public function setAge(int $age)'
subst = 'public function set$1?$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result