using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!\.jpg$|\.png$|\.js$|\.css$).)*$";
string input = @"https://asfasdf.com/xxx/123
https://asfasdf.com/xxx/123.jpg
https://asfasdf.com/xxx/123.png
https://asfasdf.com/xxx/123.css
https://asfasdf.com/xxx/123.CSs
https://asfasdf.com/xxx/123.js
https://asfasdf.com/xxx/123.html";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}