import Foundation
let pattern = #"^((?!\.jpg$|\.png$|\.js$|\.css$).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://asfasdf.com/xxx/123
https://asfasdf.com/xxx/123.jpg
https://asfasdf.com/xxx/123.png
https://asfasdf.com/xxx/123.css
https://asfasdf.com/xxx/123.CSs
https://asfasdf.com/xxx/123.js
https://asfasdf.com/xxx/123.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)