$re = '/\b(\d+\.\d+|NA)(?:,\1)+\b/m';
$str = '2.752,2.752,2.752,2.752,2.752,2.752,2.752,2.911,2.911,3.555
2.999,2.999,2.999,2.752,2.752,2.752,2.752
1.34,1.34,1.34,1.55,1.55,1.55,1.55,1.55,1.55,1.55
1.56,1.56,1.56,1.55,1.55,1.55,1.55,NA,NA,NA,NA,1.34,1.34,1.34
NA,NA,NA,0.147,0.147,0.147,0.147,0.147,NA
0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;