$re = '/<script.*?>[\s\S]*?<\/script>/i';
$str = '<script>alert(document.cookie);</script>
<script>alert(document.cookie);</script><script>alert(document.cookie);</script>
<script>
if(true===false){
}
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);