re = /<script.*?>[\s\S]*?<\/script>/i
str = '<script>alert(document.cookie);</script>
<script>alert(document.cookie);</script><script>alert(document.cookie);</script>
<script>
if(true===false){
}
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end