#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[\d+\:\d+\:\d+\s(INFO|WARN|ERROR)\]\:\s"
Local $sString = "Feb 08 17:14:35 [16:14:35 INFO]: [Vault] No new version available" & @CRLF & _
"Feb 08 19:42:41 [18:42:41 INFO]: CONSOLE issued server command: /help" & @CRLF & _
"Feb 08 19:42:41 [18:42:41 INFO]: To view help from the console, type '?'." & @CRLF & _
"Feb 08 19:42:55 [18:42:55 INFO]: -------------------- Help --------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")