package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\d+\:\d+\:\d+\s(INFO|WARN|ERROR)\]\:\s`)
var str = `Feb 08 17:14:35 [16:14:35 INFO]: [Vault] No new version available
Feb 08 19:42:41 [18:42:41 INFO]: CONSOLE issued server command: /help
Feb 08 19:42:41 [18:42:41 INFO]: To view help from the console, type '?'.
Feb 08 19:42:55 [18:42:55 INFO]: -------------------- Help --------------------`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}