// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*[\/\\])?([\w\-_]*)((?:\.\w+)*)?$").unwrap();
let string = "/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.test.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper.sh
python-tests_wrapper
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper
python-tests_wrapper.test.sh
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}