use strict;
my $str = 'MFTF2LH_LSetC1_D-05_cold_fa00_bpmax
MFTF2LH_LSetC1_D-08_hot43_fa00_bpmax
MFTF2LH_LSetC1_D-09_hot43_fa00_bpmax
MFTF2LH_LSetC1_D-10_hot43_fa00_bpmax
MFTF2LH_LSetC1_D-11_hot43_fa00_bpmax
MFTF2LH_LSetC1_D-08_hot50_fa00_bpmax
MFTF2LH_LSetC1_D-09_hot50_fa00_bpmax
MFTF2LH_LSetC1_D-10_hot50_fa00_bpmax
MFTF2LH_LSetC1_D-11_hot50_fa00_bpmax
MFTF2LH_LSetC1_D-01_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-02_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-03_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-04_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-05_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-06_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-07_hot56_fa00_bpmax
MFTF2LH_LSetC1_D-07_cold_fa00_bpmin
MFTF2LH_LSetC1_D-08_cold_fa00_bpmin
MFTF2LH_LSetC1_D-09_cold_fa00_bpmin
MFTF2LH_LSetC1_D-04_hot50_fa00_bpmax
MFTF2LH_LSetC1_D-07_hot43_fa00_bpmax
MFTF2LH_LSetC1_D-10_hot56_fa00_bpmax';
my $regex = qr/(_D-0[1-7]_hot(43|50)|_D-0[8,9]_hot56|_D-1[0,1]_hot56)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}