package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)href="([^"]+)"[^>]*?>[^<]*?skirt[^<]*?<`)
var str = `<a href="/clothing/jacket/">Jacket</a>
<a href="/clothing/Socks/">Socks</a>
<a href="/clothing/Shoes/">Shoes</a>
<a href="/clothing/xx_Sk0rt/" class="xxx">test Skirt test</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}