using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?{""EVENT_NAME"":""(?<tag6>[^""]*)"",""EVENT_ID"":""(?<action>[^""]*)"",""User_Id"":""(?<login>[^""]*)"",""X_Corelation_ID"":""(?<policy>[^""]*)"",""Client_IPAddress"":""(?<sip>[^""]*)"",""Acting_As_ID"":""(?<account>[^""]*)"",""Message"":""(?<tag2>[^""]*)""}";
string input = @"[2019-01-15 13:44:43,432] [[ACTIVE] ExecuteThread: '45' for queue: 'weblogic.kernel.Default (self-tuning)'] WARN SiemLogger - {""EVENT_NAME"":""SIEM"",""EVENT_ID"":""LOGOUT"",""User_Id"":""ROBKNT1810"",""X_Corelation_ID"":""null"",""Client_IPAddress"":""null"",""Acting_As_ID"":""null"",""Message"":""MobileSignOutPage - User successfully logged out.""}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}