import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?\\{\"EVENT_NAME\":\"(?<tag6>[^\"]*)\",\"EVENT_ID\":\"(?<action>[^\"]*)\",\"User_Id\":\"(?<login>[^\"]*)\",\"X_Corelation_ID\":\"(?<policy>[^\"]*)\",\"Client_IPAddress\":\"(?<sip>[^\"]*)\",\"Acting_As_ID\":\"(?<account>[^\"]*)\",\"Message\":\"(?<tag2>[^\"]*)\"\\}";
final String string = "[2019-01-15 13:44:43,432] [[ACTIVE] ExecuteThread: '45' for queue: 'weblogic.kernel.Default (self-tuning)'] WARN SiemLogger - {\"EVENT_NAME\":\"SIEM\",\"EVENT_ID\":\"LOGOUT\",\"User_Id\":\"ROBKNT1810\",\"X_Corelation_ID\":\"null\",\"Client_IPAddress\":\"null\",\"Acting_As_ID\":\"null\",\"Message\":\"MobileSignOutPage - User successfully logged out.\"}\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}