#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) " & @CRLF & _
"\d+ # at least one digit" & @CRLF & _
"\. # a period" & @CRLF & _
"\s # a space" & @CRLF & _
"[^\d]++ # not a digit, 1 or more of them" & @CRLF & _
"(?=\d) # until we see a digit ahead" & @CRLF & _
""
Local $sString = " 1. Which is your primary browser for development 2. Which of the following technologies have you made use of? 2. Which of the following technologies have you made use of? 3. How old "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")