#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{1,2}\: (.+)\: \<(.+)\>.*mtu (\d+).*state (UP|DOWN|UNKNOWN).*\n.*|\n.*inet (\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\/\d{1,2})"
Local $sString = "1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000" & @CRLF & _
" link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00" & @CRLF & _
" inet 127.0.0.1/8 scope host lo" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
" inet6 ::1/128 scope host" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000" & @CRLF & _
" link/ether b8:27:eb:30:65:42 brd ff:ff:ff:ff:ff:ff" & @CRLF & _
"3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000" & @CRLF & _
" link/ether b8:27:eb:65:30:17 brd ff:ff:ff:ff:ff:ff" & @CRLF & _
" inet 192.168.178.22/24 brd 192.168.178.255 scope global dynamic noprefixroute wlan0" & @CRLF & _
" valid_lft 861425sec preferred_lft 753425sec" & @CRLF & _
" inet6 fe80::d32b:df6a:d0e1:d925/64 scope link" & @CRLF & _
" valid_lft forever preferred_lft forever"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")