re = /\b[a-z0-9]{6}\b/
str = 'abcdef abc 987 hello1 123456 abcde abcdefg 1234567 fedcba'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end