#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*(?:[&,]|Featuring).*"
Local $sString = "Drake" & @CRLF & _
"Post Malone Featuring Ty Dolla $ign" & @CRLF & _
"BlocBoy JB Featuring Drake" & @CRLF & _
"Offset & Metro Boomin" & @CRLF & _
"Jay Rock, Kendrick Lamar, Future & James Blake"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)