package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?:[&,]|Featuring).*`)
var str = `Drake
Post Malone Featuring Ty Dolla $ign
BlocBoy JB Featuring Drake
Offset & Metro Boomin
Jay Rock, Kendrick Lamar, Future & James Blake`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}