const regex = new RegExp('\\s*(?:[&,]|Featuring).*', 'g')
const str = `Drake
Post Malone Featuring Ty Dolla \$ign
BlocBoy JB Featuring Drake
Offset & Metro Boomin
Jay Rock, Kendrick Lamar, Future & James Blake`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);