import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(I[VX]|VI{0,3}|I{1,3})|((X[LC]|LX{0,3}|X{1,3})(I[VX]|V?I{0,3}))|((C[DM]|DC{0,3}|C{1,3})(X[LC]|L?X{0,3})(I[VX]|V?I{0,3}))|(M+(C[DM]|D?C{0,3})(X[LC]|L?X{0,3})(I[VX]|V?I{0,3}))$";
final String string = "I\n"
+ "II\n"
+ "III\n"
+ "IV\n"
+ "V\n"
+ "VI\n"
+ "VII\n"
+ "VIII\n"
+ "IX\n"
+ "X\n"
+ "XI\n"
+ "XII\n"
+ "XIII\n"
+ "XIV\n"
+ "XV\n"
+ "XVI\n"
+ "XVII\n"
+ "XVIII\n"
+ "XIX\n"
+ "XX\n"
+ "XLIV\n"
+ "XLIX\n"
+ "LXXIX\n"
+ "XCIV\n"
+ "XCIX\n"
+ "C\n"
+ "CI\n"
+ "CII\n"
+ "CIII\n"
+ "CIV\n"
+ "CVI\n"
+ "CIX\n"
+ "CD\n"
+ "CM\n"
+ "CC\n"
+ "CCC\n"
+ "D\n"
+ "DC\n"
+ "DCC\n"
+ "DCCC\n"
+ "CX\n"
+ "CXX\n"
+ "CXIX\n"
+ "CMXCIX\n"
+ "MCMXLIV\n"
+ "MMMMCCCXII\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}