# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(I[VX]|VI{0,3}|I{1,3})|((X[LC]|LX{0,3}|X{1,3})(I[VX]|V?I{0,3}))|((C[DM]|DC{0,3}|C{1,3})(X[LC]|L?X{0,3})(I[VX]|V?I{0,3}))|(M+(C[DM]|D?C{0,3})(X[LC]|L?X{0,3})(I[VX]|V?I{0,3}))$"
test_str = ("I\n"
"II\n"
"III\n"
"IV\n"
"V\n"
"VI\n"
"VII\n"
"VIII\n"
"IX\n"
"X\n"
"XI\n"
"XII\n"
"XIII\n"
"XIV\n"
"XV\n"
"XVI\n"
"XVII\n"
"XVIII\n"
"XIX\n"
"XX\n"
"XLIV\n"
"XLIX\n"
"LXXIX\n"
"XCIV\n"
"XCIX\n"
"C\n"
"CI\n"
"CII\n"
"CIII\n"
"CIV\n"
"CVI\n"
"CIX\n"
"CD\n"
"CM\n"
"CC\n"
"CCC\n"
"D\n"
"DC\n"
"DCC\n"
"DCCC\n"
"CX\n"
"CXX\n"
"CXIX\n"
"CMXCIX\n"
"MCMXLIV\n"
"MMMMCCCXII\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.