const regex = /\d{3}.\d{3}.\d{3}-\d{2}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}.\\d{3}.\\d{3}-\\d{2}', 'gmi')
const str = `CPF dos aprovados:
- 600.567.890-12
- 765.998.345-23
- 107.628.558-94
- 467.972.058-16
- 282.943.513-34
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}