const regex = /<img\s(.*?)scr="((.*?)\/test234\/(.*?))"(.*?)>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\s(.*?)scr="((.*?)\\\/test234\\\/(.*?))"(.*?)>', '')
const str = `Das ist ein Test <img scr="././test234/12345.jpg" border="0" alt="test"> bla blub blabub`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}