// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img\s(.*?)scr="((.*?)\/test234\/(.*?))"(.*?)>"#).unwrap();
let string = "Das ist ein Test <img scr=\"././test234/12345.jpg\" border=\"0\" alt=\"test\"> bla blub blabub";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}