re = /.*?(<h2 itemprop="name">\s*<a.*?<\/h2>\s?|$)/i
str = '<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/1page.html">Page1</a></h2>
<Лишний код>
<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/2page.html">Page2</a></h2>
<Лишний код>
<Лишний код>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result