package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(0[1-9]|1[0-2])[\/\-](0[1-9]|1[\d]|2[\d]|3[01])[\/\-](\d{2,4})`)
var str = `31/12/2019
12/12/2029
12-19-19
19-23-2019
01-23-2018
15-89-2019
02-26-1974
02-50-1978
11/05/19`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}