# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(0[1-9]|1[0-2])[\/\-](0[1-9]|1[\d]|2[\d]|3[01])[\/\-](\d{2,4})"
test_str = ("31/12/2019\n"
"12/12/2029\n"
"12-19-19\n"
"19-23-2019\n"
"01-23-2018\n"
"15-89-2019\n"
"02-26-1974\n"
"02-50-1978\n"
"11/05/19")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.