# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+):\s*
(
"[^"]*",? # qualquer coisa entre aspas, vírgula opcional
|[^\n\w]+ # só pra pegar o [{ depois de options
)/\"$1\": $2/gmx;t' <<< " options: [{
value: \"120\",
id: \"40\",
title: \"1400g\",
name: \"Tamanho: 123\"
},
{
value: \"336\",
id: \"60\",
title: \"Chocolate\",
name: \"Sabor\"
}
]"